[ 
https://issues.apache.org/jira/browse/LUCENE-8152?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Horatiu Lazu updated LUCENE-8152:
---------------------------------
    Attachment: LUCENE-8152.patch

> Simplify conditionals in JoinUtil 
> ----------------------------------
>
>                 Key: LUCENE-8152
>                 URL: https://issues.apache.org/jira/browse/LUCENE-8152
>             Project: Lucene - Core
>          Issue Type: Improvement
>            Reporter: Horatiu Lazu
>            Priority: Trivial
>         Attachments: LUCENE-8152.patch
>
>          Time Spent: 10m
>  Remaining Estimate: 0h
>
> The following could be simplified, on line 249:
> {code:java}
> int dvDocID = numericDocValues.docID();
> if (dvDocID < doc) {
>   dvDocID = numericDocValues.advance(doc);
> }
> long value;
> if (dvDocID == doc) {
>   value = numericDocValues.longValue();
> } else {
>   value = 0;
> }
> {code}
> To:
> {code:java}
> long value = 0;
> if (numericDocValues.advanceExact(doc)) {
>   value = numericDocValues.longValue();
> }
> {code}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscr...@lucene.apache.org
For additional commands, e-mail: dev-h...@lucene.apache.org

Reply via email to