David Smiley commented on SOLR-11670:

[~ab] I think it's confusing that TimeSource.getTime & getEpochTime return 
nanoseconds.  I think the methods should be renamed so that it's clear what 
unit it is, otherwise the conditions are ripe for continuing bugs in unit 
conversions.  Perhaps rename getTime to {{getTimeNs}}.

> Implement a periodic house-keeping task
> ---------------------------------------
>                 Key: SOLR-11670
>                 URL: https://issues.apache.org/jira/browse/SOLR-11670
>             Project: Solr
>          Issue Type: Sub-task
>      Security Level: Public(Default Security Level. Issues are Public) 
>          Components: AutoScaling
>            Reporter: Andrzej Bialecki 
>            Assignee: Andrzej Bialecki 
>            Priority: Major
>         Attachments: SOLR-11670.patch, SOLR-11670.patch, SOLR-11670.patch
> Some high-impact cluster changes (such as split shard) leave the original 
> data and original state that is no longer actively used. This makes sense due 
> to safety reasons and to make it easier to roll-back the changes.
> However, this unused data will accumulate over time, especially when actions 
> like split shard are invoked automatically by the autoscaling framework. We 
> need a periodic task that would clean up this kind of data after a certain 
> period.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: dev-unsubscr...@lucene.apache.org
For additional commands, e-mail: dev-h...@lucene.apache.org

Reply via email to