[ 
https://issues.apache.org/jira/browse/LUCENE-8242?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16428210#comment-16428210
 ] 

Alan Woodward commented on LUCENE-8242:
---------------------------------------

We have two createWeight() functions in IndexSearcher:
{code}
public Weight createNormalizedWeight(Query query, ScoreMode scoreMode) throws 
IOException
public Weight createWeight(Query query, ScoreMode scoreMode, float boost) 
throws IOException
{code}

The first rewrites, and then delegates to the second with a boost of 1.  I 
think we should rename it to 'rewriteAndCreateWeight', as that's what it 
actually does.

> Rename IndexSearcher.createNormalizedWeight()
> ---------------------------------------------
>
>                 Key: LUCENE-8242
>                 URL: https://issues.apache.org/jira/browse/LUCENE-8242
>             Project: Lucene - Core
>          Issue Type: Improvement
>            Reporter: Alan Woodward
>            Assignee: Alan Woodward
>            Priority: Major
>
> We don't have Weight normalization since LUCENE-7368, so this method name is 
> just plain wrong.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscr...@lucene.apache.org
For additional commands, e-mail: dev-h...@lucene.apache.org

Reply via email to