Mike Sokolov created LUCENE-8248:

             Summary: Make MergePolicy.setMaxCFSSegmentSizeMB final
                 Key: LUCENE-8248
                 URL: https://issues.apache.org/jira/browse/LUCENE-8248
             Project: Lucene - Core
          Issue Type: Wish
          Components: core/index
            Reporter: Mike Sokolov
         Attachments: MergePolicy.patch

MergePolicy.getMaxCFSSegmentSizeMB is final, but the corresponding setter is 
not, which means that overriding it with anything other than a trivial 
delegation can only lead to confusion.

The patch makes the method final and removes the trivial implementations from 
MergePolicyWrapper and NoMergePolicy.

[~mikemccand] also pointed out that the class name is nonstandard for similar 
adapter classes in Lucene, which are usually Filter*.java. Personally I was 
looking for MergePolicyAdapter, but if there is a prevailing convention here 
around Filter, does it make sense to change this class's name to 

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: dev-unsubscr...@lucene.apache.org
For additional commands, e-mail: dev-h...@lucene.apache.org

Reply via email to