[
https://issues.apache.org/jira/browse/LUCENE-8622?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16734119#comment-16734119
]
David Smiley commented on LUCENE-8622:
--------------------------------------
Cool algorithms here.
Can you please rename CacheingMatchesIterator to CachingMatchesIterator (drop
the first 'e')
A comment referred to "phrasequeue" but I think "proximityQueue" is more
correct.
> Add a MinimumShouldMatch interval iterator
> ------------------------------------------
>
> Key: LUCENE-8622
> URL: https://issues.apache.org/jira/browse/LUCENE-8622
> Project: Lucene - Core
> Issue Type: Task
> Reporter: Alan Woodward
> Assignee: Alan Woodward
> Priority: Major
> Attachments: LUCENE-8622.patch, LUCENE-8622.patch
>
>
> It would be useful to be able to search for intervals that span some subgroup
> of a set of iterators, allowing us to build a 'some of ' or 'at least'
> operator - ie, search for terms that appear near at least 3 of a list of 5
> terms.
--
This message was sent by Atlassian JIRA
(v7.6.3#76005)
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]