[
https://issues.apache.org/jira/browse/LUCENE-3466?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13115443#comment-13115443
]
Robert Muir commented on LUCENE-3466:
-------------------------------------
+1, though i have a few additional suggestions:
* TokenStream.reset() is described by the docs as optional, i think we should
adjust the docs here.
* We might be able to re-word some of the stuff in Analyzer javadocs about
inconsistencies (Since these are gone!)
> Rename Analyzer.reusableTokenStream() to tokenStream()
> ------------------------------------------------------
>
> Key: LUCENE-3466
> URL: https://issues.apache.org/jira/browse/LUCENE-3466
> Project: Lucene - Java
> Issue Type: Sub-task
> Components: modules/analysis
> Reporter: Chris Male
> Assignee: Chris Male
> Attachments: LUCENE-3466.patch
>
>
> All Analysis consumers now use reusableTokenStream(). To finally make reuse
> mandatory, lets rename resuableTokenStream() to tokenStream() (removing the
> old tokenStream() method).
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]