[ https://issues.apache.org/jira/browse/LUCENE-4663?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13545964#comment-13545964 ]
Michael McCandless commented on LUCENE-4663: -------------------------------------------- +1 > IndexSearcher.document() should not be final > -------------------------------------------- > > Key: LUCENE-4663 > URL: https://issues.apache.org/jira/browse/LUCENE-4663 > Project: Lucene - Core > Issue Type: Bug > Reporter: Robert Muir > Attachments: LUCENE-4663.patch > > > IndexSearcher has 3 methods: > {noformat} > StoredDocument doc(int) > void doc(int, StoredFieldVisitor) > final StoredDocument document(int, Set<String>) > {noformat} > The last one is confusing for subclasses (e.g. SolrIndexSearcher) that > override these methods. for example that one has its own StoredDocument > doc(int, Set) method. > But now this means a user could always call the wrong method (this final > document() method) and get the wrong behavior (versus calling doc()). > I think the name is also wrong. it should be doc() like the others. -- This message is automatically generated by JIRA. If you think it was sent incorrectly, please contact your JIRA administrators For more information on JIRA, see: http://www.atlassian.com/software/jira --------------------------------------------------------------------- To unsubscribe, e-mail: dev-unsubscr...@lucene.apache.org For additional commands, e-mail: dev-h...@lucene.apache.org