[
https://issues.apache.org/jira/browse/LUCENE-4374?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13610783#comment-13610783
]
Commit Tag Bot commented on LUCENE-4374:
----------------------------------------
[branch_4x commit] David Wayne Smiley
http://svn.apache.org/viewvc?view=revision&revision=1388904
LUCENE-4374 Rename TwoDoubles to PointVector
> Spatial- rename vector.TwoDoublesStrategy to vector.PointVectorStrategy
> -----------------------------------------------------------------------
>
> Key: LUCENE-4374
> URL: https://issues.apache.org/jira/browse/LUCENE-4374
> Project: Lucene - Core
> Issue Type: Improvement
> Components: modules/spatial
> Reporter: David Smiley
> Assignee: David Smiley
> Fix For: 4.0
>
> Attachments: LUCENE-4374_Rename_TwoDoubles_to_PointVector.patch
>
>
> TwoDoubles isn't necessarily appropriate since it could be two floats, once
> it is enhanced to make that configurable. I like PointVector because it's
> clear it indexes points. Eventually I could imagine a CircleVectorStrategy
> in the same package.
> This does suggest BBoxStrategy should be RectVectorStrategy in the vector
> package.
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]