[ 
https://issues.apache.org/jira/browse/MAHOUT-1374?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13951793#comment-13951793
 ] 

Sebastian Schelter commented on MAHOUT-1374:
--------------------------------------------

Hi, thank you for the patch, in general it looks very good but it needs a bit 
more work.

Please ensure that the code is formatted according to Mahout's code 
conventions. We use the standard Sun code conventions with the exception that 
an indent is 2 spaces and a line can be 120 characters long. Check some of the 
other classes of mahout to see the style.

Some details: 
 * add a license header to newly created files
 * replace tabs with 2 spaces
 * use the general type Map not HashMap for userItemFilter
 *  you have a method that isUserItemFilterSpecified that checks whether 
userItemFile is null, use that in the code and create something similar for the 
other null checks, it makes your code much more readable

> Ability to provide input file with userid, itemid pair
> ------------------------------------------------------
>
>                 Key: MAHOUT-1374
>                 URL: https://issues.apache.org/jira/browse/MAHOUT-1374
>             Project: Mahout
>          Issue Type: Improvement
>          Components: Collaborative Filtering
>    Affects Versions: 0.8
>            Reporter: Romit Singhai
>             Fix For: 1.0
>
>         Attachments: MAHOUT-1374.patch
>
>
> Currently while running the itembased recommender from the command line, user 
> can get recommendation for a particular set of users by using the userFile 
> option or for particular set of itemId's by using the itemFile option. Using 
> these option together seems to provide recommendations for the cross product 
> for the two inputs. We need an option say userItemFile where a coma separated 
> userid,itemid pair is provide on each line as input and output will be 
> userid,itemid,recommendation. This functionality will be very useful for lot 
> users.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Reply via email to