Hi Karl,
I have set the environment variable  *SL_CHROME_DRIVER*

this is the error message in plain text

Behaviour=}]
    [junit] Session ID: 3ad1b9e6f76c135667ad37cbbe571974
    [junit]     at
java.lang.reflect.Constructor.newInstance(Constructor.java:423)
    [junit]     at
org.openqa.selenium.remote.ErrorHandler.createThrowable(ErrorHandler.java:216)
    [junit]     at
org.openqa.selenium.remote.ErrorHandler.throwIfResponseFailed(ErrorHandler.java:168)
    [junit]     at
org.openqa.selenium.remote.RemoteWebDriver.execute(RemoteWebDriver.java:638)
    [junit]     at
org.openqa.selenium.remote.RemoteWebDriver.get(RemoteWebDriver.java:325)
    [junit]     at
org.apache.manifoldcf.core.tests.SeleniumTester.start(SeleniumTester.java:111)
    [junit]     at
org.apache.manifoldcf.authorities.authorities.activedirectory.tests.NavigationHSQLDBUI.createConnectionsAndJob(NavigationHSQLDBUI.java:40)
    [junit]
    [junit]

BUILD FAILED
D:\RC0\apache-manifoldcf-2.10-src\apache-manifoldcf-2.10\build.xml:498: The
following error occurred while executing this line:
D:\RC0\apache-manifoldcf-2.10-src\apache-manifoldcf-2.10\build.xml:436: The
following error occurred while executing this line:
D:\RC0\apache-manifoldcf-2.10-src\apache-manifoldcf-2.10\dist\connector-build.xml:1192:
Test
org.apache.manifoldcf.authorities.authorities.activedirectory.tests.NavigationHSQLDBUI
failed

On 11 July 2018 at 19:55, Karl Wright <daddy...@gmail.com> wrote:

> I am not seeing the graphic.
> You also need to set the proper environment variables to point at your
> selenium installation.
>
> Karl
>
>
> On Wed, Jul 11, 2018 at 10:24 AM Irindu Nugawela <nbiinde...@gmail.com>
> wrote:
>
> > Hi Karl,
> >
> > Thank you for the tip. I installed selenium but still the UI test fails.
> > Here is the error
> >
> >
> >
> >
> > On 11 July 2018 at 15:42, Karl Wright <daddy...@gmail.com> wrote:
> >
> >> Have you installed Selenium?
> >>
> >> Karl
> >>
> >>
> >> On Wed, Jul 11, 2018 at 3:40 AM Irindu Nugawela <nbiinde...@gmail.com>
> >> wrote:
> >>
> >> > Hi All,
> >> >
> >> > I am trying to execute UI tests of CMIS and ElasticSearch connectors
> but
> >> > their respective build files do not have a target to run UI tests
> >> instead
> >> > in the parent build.xml which is in the project root I found the
> target
> >> > "uitest" which is supposed to run all the UI tests but executing "*ant
> >> > uitest*" fails with the following exception
> >> >
> >> >    [junit] Testcase:
> >> >
> >> createConnectionsAndJob(org.apache.manifoldcf.authorities.
> authorities.activedirectory.tests.NavigationHSQLDBUI):
> >> > Caused an ERROR
> >> >     [junit] The driver executable does not exist:
> >> >
> >> D:\gitBlunder\manifoldcf\connectors\activedirectory\
> test-HSQLDB-output\${env.SL_CHROME_DRIVER}
> >> >     [junit] java.lang.IllegalStateException: The driver executable
> does
> >> > not exist:
> >> >
> >> D:\gitBlunder\manifoldcf\connectors\activedirectory\
> test-HSQLDB-output\${env.SL_CHROME_DRIVER}
> >> >     [junit]     at
> >> > com.google.common.base.Preconditions.checkState(
> Preconditions.java:518)
> >> >     [junit]     at
> >> >
> >> org.openqa.selenium.remote.service.DriverService.
> checkExecutable(DriverService.java:123)
> >> >     [junit]     at
> >> >
> >> org.openqa.selenium.remote.service.DriverService.
> findExecutable(DriverService.java:118)
> >> >     [junit]     at
> >> >
> >> org.openqa.selenium.chrome.ChromeDriverService.access$
> 000(ChromeDriverService.java:32)
> >> >     [junit]     at
> >> >
> >> org.openqa.selenium.chrome.ChromeDriverService$Builder.
> findDefaultExecutable(ChromeDriverService.java:137)
> >> >     [junit]     at
> >> >
> >> org.openqa.selenium.remote.service.DriverService$Builder.
> build(DriverService.java:302)
> >> >     [junit]     at
> >> >
> >> org.openqa.selenium.chrome.ChromeDriverService.createDefaultService(
> ChromeDriverService.java:88)
> >> >     [junit]     at
> >> > org.openqa.selenium.chrome.ChromeDriver.<init>(ChromeDriver.java:156)
> >> >     [junit]     at
> >> >
> >> org.apache.manifoldcf.core.tests.SeleniumTester.start(
> SeleniumTester.java:86)
> >> >     [junit]     at
> >> >
> >> org.apache.manifoldcf.authorities.authorities.activedirectory.tests.
> NavigationHSQLDBUI.createConnectionsAndJob(NavigationHSQLDBUI.java:40)
> >> >     [junit]
> >> >     [junit]
> >> >
> >> > BUILD FAILED
> >> > D:\gitBlunder\manifoldcf\build.xml:498: The following error occurred
> >> while
> >> > executing this line:
> >> > D:\gitBlunder\manifoldcf\build.xml:436: The following error occurred
> >> while
> >> > executing this line:
> >> > D:\gitBlunder\manifoldcf\dist\connector-build.xml:1192: Test
> >> >
> >> org.apache.manifoldcf.authorities.authorities.activedirectory.tests.
> NavigationHSQLDBUI
> >> > failed
> >> >
> >> > ‚Äč
> >> >
> >> >
> >> > (I have also attached the screenshot)
> >> >
> >> > Please help me run the UI tests and also let me know if there is a way
> >> to
> >> > invoke the UI tests for a particular Connector instead of running all
> >> the
> >> > UI tests.
> >> >
> >> > --
> >> > Thanks and Regards,
> >> > Irindu Nugawela,
> >> > Computer Engineering <http://www.ce.pdn.ac.lk/> Undergraduate,
> >> > Faculty of Engineering University of Peradeniya
> >> >
> >>
> >
> >
> >
> > --
> > Thanks and Regards,
> > Irindu Nugawela,
> > Computer Engineering <http://www.ce.pdn.ac.lk/> Undergraduate,
> > Faculty of Engineering University of Peradeniya
> >
>



-- 
Thanks and Regards,
Irindu Nugawela,
Computer Engineering <http://www.ce.pdn.ac.lk/> Undergraduate,
Faculty of Engineering University of Peradeniya

Reply via email to