please use Maven users list
please don't hijack a mail thread

no idea of what happens: my next step would be to use command line instead of 
magical run from an IDE

let's continue on users list

Regards,

Hervé

Le mardi 18 octobre 2016 13:24:00 vous avez écrit :
> Hi Maven Developers/Herve:
> 
> Good day to you all. I am sending this out of desperation. My name is Gopal.
> I really could use some help.
 
> I am not an expert at maven. Here’s the scenario.
> 
> My entire project compiles without any errors under jdk1.7 …. The pom works.
> 
 
> I use artifactory to store common libraries. Under jdk 1.7, they got
> resolved without any problems. All I did was to change the jdk from 1.7 to
> 1.8. I am using intellij 2016. I change the jdk version using
 Run  Edit
> Configuration -- > select the maven configuration  Runner tab  1.8 
> However, if change the jdk version to jdk 1.8, no other changes ...
> 
> I get errors on dependency resolution …
> 
> [ERROR] Failed to execute goal on project modulecore: Could not resolve
> dependencies for project com.adp.sass:modulecore:jar:1.0.0-SNAPSHOT: Failed
> to collect dependencies at com.adp.sass:sasscommon:jar:1.0.0-SNAPSHOT:
> Failed to read artifact descriptor for
> com.adp.sass:sasscommon:jar:1.0.0-SNAPSHOT: Failure to find
> com.adp.sass:sassbuild:pom:1.0.0 in
> http://avsf-depsvr01:8082/artifactory/Proper-Resolution was cached in the
> local repository, resolution will not be reattempted until the update
> interval of Proper-Resolution has elapsed or updates are forced -> [Help
> 1]
 org.apache.maven.lifecycle.LifecycleExecutionException: Failed to
> execute goal on project modulecore: Could not resolve dependencies for
> project com.adp.sass:modulecore:jar:1.0.0-SNAPSHOT: Failed to collect
> dependencies at com.adp.sass:sasscommon:jar:1.0.0-SNAPSHOT at
> org.apache.maven.lifecycle.internal.LifecycleDependencyResolver.getDependen
> cies(LifecycleDependencyResolver.java:221) at
> org.apache.maven.lifecycle.internal.LifecycleDependencyResolver.resolveProj
> ectDependencies(LifecycleDependencyResolver.java:127) at
> org.apache.maven.lifecycle.internal.MojoExecutor.ensureDependenciesAreResol
> ved(MojoExecutor.java:245) at
> org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:
> 199) at
> org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:
> 153) at
> org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:
> 145) at
> org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(Lif
> ecycleModuleBuilder.java:116) at
> org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(Lif
> ecycleModuleBuilder.java:80) at
> org.apache.maven.lifecycle.internal.builder.singlethreaded.SingleThreadedBu
> ilder.build(SingleThreadedBuilder.java:51) at
> org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStart
> er.java:128) at
> org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:307) at
> org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:193) at
> org.apache.maven.DefaultMaven.execute(DefaultMaven.java:106) at
> org.apache.maven.cli.MavenCli.execute(MavenCli.java:863) at
> org.apache.maven.cli.MavenCli.doMain(MavenCli.java:288) at
> org.apache.maven.cli.MavenCli.main(MavenCli.java:199) at
> sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:6
> 2) at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImp
> l.java:43) at java.lang.reflect.Method.invoke(Method.java:498) at
> org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.j
> ava:289) at
> org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:229)
> at
> org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher
> .java:415) at
> org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:356)
> at org.codehaus.classworlds.Launcher.main(Launcher.java:47) Caused by:
> org.apache.maven.project.DependencyResolutionException: Could not resolve
> dependencies for project com.adp.sass:modulecore:jar:1.0.0-SNAPSHOT: Failed
> to collect dependencies at com.adp.sass:sasscommon:jar:1.0.0-SNAPSHOT at
> org.apache.maven.project.DefaultProjectDependenciesResolver.resolve(Default
> ProjectDependenciesResolver.java:180) at
> org.apache.maven.lifecycle.internal.LifecycleDependencyResolver.getDependen
> cies(LifecycleDependencyResolver.java:195) ... 24 more
> Caused by: org.eclipse.aether.collection.DependencyCollectionException:
> Failed to collect dependencies at
> com.adp.sass:sasscommon:jar:1.0.0-SNAPSHOT
 at
> org.eclipse.aether.internal.impl.DefaultDependencyCollector.collectDependen
> cies(DefaultDependencyCollector.java:291) at
> org.eclipse.aether.internal.impl.DefaultRepositorySystem.collectDependencie
> s(DefaultRepositorySystem.java:316) at
> org.apache.maven.project.DefaultProjectDependenciesResolver.resolve(Default
> ProjectDependenciesResolver.java:172) ... 25 more
> Caused by: org.eclipse.aether.resolution.ArtifactDescriptorException: Failed
> to read artifact descriptor for com.adp.sass:sasscommon:jar:1.0.0-SNAPSHOT
> at
> org.apache.maven.repository.internal.DefaultArtifactDescriptorReader.loadPo
> m(DefaultArtifactDescriptorReader.java:329) at
> org.apache.maven.repository.internal.DefaultArtifactDescriptorReader.readAr
> tifactDescriptor(DefaultArtifactDescriptorReader.java:198) at
> org.eclipse.aether.internal.impl.DefaultDependencyCollector.resolveCachedAr
> tifactDescriptor(DefaultDependencyCollector.java:535) at
> org.eclipse.aether.internal.impl.DefaultDependencyCollector.getArtifactDesc
> riptorResult(DefaultDependencyCollector.java:519) at
> org.eclipse.aether.internal.impl.DefaultDependencyCollector.processDependen
> cy(DefaultDependencyCollector.java:409) at
> org.eclipse.aether.internal.impl.DefaultDependencyCollector.processDependen
> cy(DefaultDependencyCollector.java:363) at
> org.eclipse.aether.internal.impl.DefaultDependencyCollector.process(Default
> DependencyCollector.java:351) at
> org.eclipse.aether.internal.impl.DefaultDependencyCollector.collectDependen
> cies(DefaultDependencyCollector.java:254) ... 27 more
> Caused by: org.apache.maven.model.resolution.UnresolvableModelException:
> Failure to find com.adp.sass:sassbuild:pom:1.0.0 in
> http://avsf-depsvr01:8082/artifactory/Proper-Resolution was cached in the
> local repository, resolution will not be reattempted until the update
> interval of Proper-Resolution has elapsed or updates are forced
 at
> org.apache.maven.repository.internal.DefaultModelResolver.resolveModel(Defa
> ultModelResolver.java:177) at
> org.apache.maven.repository.internal.DefaultModelResolver.resolveModel(Defa
> ultModelResolver.java:226) at
> org.apache.maven.model.building.DefaultModelBuilder.readParentExternally(De
> faultModelBuilder.java:1000) at
> org.apache.maven.model.building.DefaultModelBuilder.readParent(DefaultModel
> Builder.java:800) at
> org.apache.maven.model.building.DefaultModelBuilder.build(DefaultModelBuild
> er.java:329) at
> org.apache.maven.repository.internal.DefaultArtifactDescriptorReader.loadPo
> m(DefaultArtifactDescriptorReader.java:320) ... 34 more
> Caused by: org.eclipse.aether.resolution.ArtifactResolutionException:
> Failure to find com.adp.sass:sassbuild:pom:1.0.0 in
> http://avsf-depsvr01:8082/artifactory/Proper-Resolution was cached in the
> local repository, resolution will not be reattempted until the update
> interval of Proper-Resolution has elapsed or updates are forced
 at
> org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArt
> ifactResolver.java:444) at
> org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifacts(D
> efaultArtifactResolver.java:246) at
> org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifact(De
> faultArtifactResolver.java:223) at
> org.apache.maven.repository.internal.DefaultModelResolver.resolveModel(Defa
> ultModelResolver.java:173) ... 39 more
> Caused by: org.eclipse.aether.transfer.ArtifactNotFoundException: Failure to
> find com.adp.sass:sassbuild:pom:1.0.0 in
> http://avsf-depsvr01:8082/artifactory/Proper-Resolution was cached in the
> local repository, resolution will not be reattempted until the update
> interval of Proper-Resolution has elapsed or updates are forced
 at
> org.eclipse.aether.internal.impl.DefaultUpdateCheckManager.newException(Def
> aultUpdateCheckManager.java:231) at
> org.eclipse.aether.internal.impl.DefaultUpdateCheckManager.checkArtifact(De
> faultUpdateCheckManager.java:206) at
> org.eclipse.aether.internal.impl.DefaultArtifactResolver.gatherDownloads(De
> faultArtifactResolver.java:585) at
> org.eclipse.aether.internal.impl.DefaultArtifactResolver.performDownloads(D
> efaultArtifactResolver.java:503) at
> org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArt
> ifactResolver.java:421) ... 42 more
> [ERROR] 
> [ERROR] 
> [ERROR] For more information about the errors and possible solutions, please
> read the following articles:
 [ERROR] [Help 1]
> http://cwiki.apache.org/confluence/display/MAVEN/DependencyResolutionExcept
> ion Disconnected from the target VM, address: '127.0.0.1:55785', transport:
> 'socket' 
> Process finished with exit code 1
> 
> Here’s my maven configuration.
> 
> C:\Users\gopalag>mvn -version
> Apache Maven 3.0.5 (r01de14724cdef164cd33c7c8c2fe155faf9602da; 2013-02-19
> 06:51:
 28-0700)
> Maven home: D:\Software\Maven\apache-maven-3.0.5\bin\..
> Java version: 1.8.0_102, vendor: Oracle Corporation
> Java home: D:\Software\Java\jdk1.8.0_102\jre
> Default locale: en_US, platform encoding: Cp1252
> OS name: "windows 7", version: "6.1", arch: "amd64", family: "dos"
> 
> We are wanting to move to jdk 1.8 … 
> I have been searching the archives to find an answer, but the problem
> baffles me …
 
> Can anyone help me, please?
> 
> 
> Thanks,
> Gopal
> 
> 
> -----Original Message-----
> From: Hervé BOUTEMY [mailto:herve.bout...@free.fr] 
> Sent: Monday, October 17, 2016 4:04 PM
> To: Maven Developers List
> Subject: Re: [VOTE] Release Apache Maven PMD Plugin version 3.7
> 
> FYI, I found the cause of the issue: this could be useful to share...
> 
> I defined a ~/.mavenrc file which defined MAVEN_OPTS env variable
> 
> since maven-invoker-plugin passed configuration from invoker.properties as
> MAVEN_OPTS env variable content, .mavenrc was just overriding
 
> I changed my .mavenrc script to contain
> MAVEN_OPTS="xxx $MAVEN_OPTS"
> and now I don't have the failure any more, as expected
> 
> HTH others when having such strange issue...
> 
> Regards,
> 
> Hervé
> 
> Le jeudi 13 octobre 2016 20:22:06 Hervé BOUTEMY a écrit :
> 
> > same issue with maven-pmd-plugin-3.6: there's something strange on my 
> > machine...
> > 
> > then +1
> > 
> > Regards,
> > 
> > Hervé
> > 
> > Le jeudi 13 octobre 2016 20:02:27 Andreas Dangel a écrit :
> > 
> > > That's weird. I don't see this... I'm on Linux, too.
> > > 
> > > Works with Java7 and maven 3.3.1, 3.3.3, 3.3.9.
> > > 
> > > The integration job seems to be ok, too:
> > > https://builds.apache.org/job/maven-plugins-ITs-m3/
> > > 
> > > Am 13.10.2016 um 19:43 schrieb Hervé BOUTEMY:
> > > 
> > > > I built the release and got a failure in an IT:
> > > > [INFO] Building: MPMD-187/pom.xml
> > > > [INFO] run script verify.groovy
> > > > [INFO] ..FAILED (4.4 s)
> > > > [INFO]   The post-build script did not succeed. assert
> > > > !pmdXml.exists()
> > > > 
> > > > 
> > > >        ||      true
> > > >        |
> > > >        |
> > > >        |/home/herve/tmp/maven-pmd-plugin-3.7/target/it/MPMD-187/target
> > > >        |/p
> > > >        |md
> > > >        |.xml
> > > >        
> > > >        
> > > >        false
> > > > 
> > > > 
> > > > I get the same result on trunk
> > > > 
> > > > Tested on Linux with JDK 7 and Maven 3.3.0 and 3.4.0-SNAPSHOT: am 
> > > > I the only one with such issue?
> > > > 
> > > > Regards,
> > > > 
> > > > Hervé
> > > > 
> > > > Le lundi 10 octobre 2016 20:15:01 Andreas Dangel a écrit :
> > > > 
> > > >> Hi,
> > > >> 
> > > >> We solved 11 issues:
> > > >> https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=
> > > >> 123176
> > > >> 21
> > > >> &ve rsion=12334373&styleName=Text
> > > >> 
> > > >> There are still a couple of issues left in JIRA:
> > > >> https://issues.apache.org/jira/issues/?jql=project%20%3D%20MPMD%2
> > > >> 0AND%2
> > > >> 0r
> > > >> eso lution%20%3D%20Unresolved%20ORDER%20BY%20priority%20DESC
> > > >> 
> > > >> Staging repo:
> > > >> https://repository.apache.org/content/repositories/maven-1287
> > > >> https://repository.apache.org/content/repositories/maven-1287/org
> > > >> /apach
> > > >> e/
> > > >> mav
> > > >> en/plugins/maven-pmd-plugin/3.7/maven-pmd-plugin-3.7-source-relea
> > > >> se.zip
> > > >> 
> > > >> Source release checksum(s):
> > > >> maven-pmd-plugin-3.7-source-release.zip sha1:
> > > >> a8ccd94fa6c41ef66ad29932027eb03ca45b402d
> > > >> 
> > > >> Staging site:
> > > >> https://maven.apache.org/plugins-archives/maven-pmd-plugin-LATEST
> > > >> /
> > > >> 
> > > >> Guide to testing staged releases:
> > > >> https://maven.apache.org/guides/development/guide-testing-release
> > > >> s.html
> > > >> 
> > > >> Vote open for 72 hours.
> > > >> 
> > > >> [ ] +1
> > > >> [ ] +0
> > > >> [ ] -1
> > > >> 
> > > >> Regards,
> > > >> Andreas
> > > >> 
> > > >> 
> > > >> 
> > > >> -----------------------------------------------------------------
> > > >> ---- To unsubscribe, e-mail: dev-unsubscr...@maven.apache.org For 
> > > >> additional commands, e-mail: dev-h...@maven.apache.org
> > > > 
> > > > 
> > > > ------------------------------------------------------------------
> > > > --- To unsubscribe, e-mail: dev-unsubscr...@maven.apache.org For 
> > > > additional commands, e-mail: dev-h...@maven.apache.org
> > 
> > 
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: dev-unsubscr...@maven.apache.org For 
> > additional commands, e-mail: dev-h...@maven.apache.org
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscr...@maven.apache.org For additional
> commands, e-mail: dev-h...@maven.apache.org
 
> 
> ----------------------------------------------------------------------
> This message and any attachments are intended only for the use of the
> addressee and may contain information that is privileged and confidential.
> If the reader of the message is not the intended recipient or an authorized
> representative of the intended recipient, you are hereby notified that any
> dissemination of this communication is strictly prohibited. If you have
> received this communication in error, notify the sender immediately by
> return email and delete the message and any attachments from your system.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscr...@maven.apache.org
For additional commands, e-mail: dev-h...@maven.apache.org

Reply via email to