-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/31228/#review78577
-----------------------------------------------------------



3rdparty/libprocess/include/process/process.hpp
<https://reviews.apache.org/r/31228/#comment127458>

    Since this function performs an action, it should be named with a verb, 
e.g. initializeDisabledEndpoints() or setDisabledEndpoints() or 
updateDisabledEndpoints().



3rdparty/libprocess/src/process.cpp
<https://reviews.apache.org/r/31228/#comment127454>

    What makes this the right place in initialize() to call this? Why not 
earlier or later?
    
    And initialize(delegate) is a non-static (library-wide?) method calling 
your new static method. Are there any problems if your method gets called 
multiple times? Could this even happen?



3rdparty/libprocess/src/process.cpp
<https://reviews.apache.org/r/31228/#comment127457>

    Since disabledHttpEndpoints is a hashset, couldn't you just use contains()?


- Adam B


On April 1, 2015, 2:50 a.m., Alexander Rojas wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/31228/
> -----------------------------------------------------------
> 
> (Updated April 1, 2015, 2:50 a.m.)
> 
> 
> Review request for mesos, Joerg Schad, Niklas Nielsen, and Till Toenshoff.
> 
> 
> Bugs: MESOS-2333
>     https://issues.apache.org/jira/browse/MESOS-2333
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Adds a mechanism for disabling http endpoints (e.g 
> `testprocess/handler1,processname(3)/handler2`). A list of coma separated 
> strings can be provided using the environment variable 
> `LIBPROCESS_DISABLED_ENDPOINTS` which will be read during libprocess 
> initialization. Then, when creating http endpoints (using the method `route`) 
> the endpoint path will be checked against the patterns. If a match is found 
> the endpoint handler will be replaced for a generic once which returns a 403 
> HTTP Error (Forbidden).
> 
> 
> Diffs
> -----
> 
>   3rdparty/libprocess/include/process/process.hpp 
> 392c74df3e8a122aecd3633dffdeec4bcbd1f097 
>   3rdparty/libprocess/src/process.cpp 
> cf4e36489be2c6aa01e838c1c71383f248deab5b 
>   3rdparty/libprocess/src/tests/process_tests.cpp 
> eb38edce2c483ba7f963a826893a15a075238618 
> 
> Diff: https://reviews.apache.org/r/31228/diff/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Alexander Rojas
> 
>

Reply via email to