I think you might be confused. The external facing flag is still `authenticate`. The internal representation of the flag has been changed to `authenticate_frameworks` a while back, as you alluded to. I added the JIRA link to the existing TODO last week :)
On Mon, Jan 18, 2016 at 1:23 AM, Alexander Rojas <alexan...@mesosphere.io> wrote: > Hey guys, > > There is already a flag called `authenticate_frameworks` which was added > as early as April 2015, it also includes a TODO pointing to the mentioned > JIRA (MESOS-4386). So I think enough time has passed to simply remove the > flag. > > Best, > > Alexander > > > On 15 Jan 2016, at 19:15, Vinod Kone <vinodk...@apache.org> wrote: > > > > Hi Disha, > > > > Thanks for asking. > > > > We cannot just rename the `authenticate` flag to > `authenticate_frameworks` > > because that will break users who are already setting that flag, when > they > > upgrade to the new version (that has this change). We always strive to do > > backwards compatible changes. > > > > The first step is to add a new flag called `authenticate_frameworks` flag > > and make sure the master does the same thing as when `authenticate` flag > is > > set. As part of this we need to 1) send an email to dev/user mailing > lists > > that this deprecation is coming and 2) update the CHANGELOG. Lets say > this > > all happens in the 0.28 release. After a few releases (to give > > users/operators enough time), we can remove the `authenticate` flag. > > > > Does that make sense? > > > > > > On Fri, Jan 15, 2016 at 9:55 AM, Disha Singh <directionsta...@gmail.com> > > wrote: > > > >> MESOS-4386 says : > >> > >> <<<<<<<To be consistent with `authenticate_slaves` and > `authenticate_http` > >> flags, we should rename `authenticate` to `authenticate_frameworks` > flag. > >> > >> This should be done via deprecation cycle. > >> > >> 1) Release X supports both `authenticate` and `authenticate_frameworks` > >> flags > >> > >> 2) Release X + n supports only `authenticate_frameworks` flag.>>>>>>>> > >> > >> How should I move ahead with resolving it ? Does it simply mean changing > >> the word "authenticate" to authenticate frameworks ? I am a newbie > .Please > >> help. :) > >> > >> > >> On Fri, Jan 15, 2016 at 11:07 PM, Artem Harutyunyan < > ar...@mesosphere.io> > >> wrote: > >> > >>> Done. Welcome to Mesos community! > >>> > >>> On Fri, Jan 15, 2016 at 9:26 AM, Disha Singh < > directionsta...@gmail.com> > >>> wrote: > >>>> Please add me to the list of Mesos contributors. I would like to > >> submit a > >>>> code review for the following JIRA: > >>>> <https://issues.apache.org/jira/browse/MESOS-4386> > >>> > >> > >