[
https://issues.apache.org/jira/browse/METAMODEL-200?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]
Kasper Sørensen updated METAMODEL-200:
--------------------------------------
Description:
In MetaModel we have a flag that can be set on e.g. "COUNT( * )" which
indicates if the database may approximate the number instead of doing a
consistent calculation. This is good for optimization scenarios where you don't
need an actual count, just an estimate (for progress bars and similar stuff in
UIs).
But unfortunately we don't have any syntax support for this when dealing with
String queries. Shouldn't we add that?
I could imagine a prefix or something like that, e.g. the "tilde / ~" symbol,
like this:
{code}
SELECT ~COUNT(*) FROM table
{code}
was:
In MetaModel we have a flag that can be set on e.g. "COUNT(*)" which indicates
if the database may approximate the number instead of doing a consistent
calculation. This is good for optimization scenarios where you don't need an
actual count, just an estimate (for progress bars and similar stuff in UIs).
But unfortunately we don't have any syntax support for this when dealing with
String queries. Shouldn't we add that?
I could imagine a prefix or something like that, e.g. the "tilde / ~" symbol,
like this:
{code}
SELECT ~COUNT(*) FROM table
{code}
> No syntax available in SQL representation of Query for "functiona
> approximation"
> --------------------------------------------------------------------------------
>
> Key: METAMODEL-200
> URL: https://issues.apache.org/jira/browse/METAMODEL-200
> Project: Apache MetaModel
> Issue Type: Bug
> Reporter: Kasper Sørensen
>
> In MetaModel we have a flag that can be set on e.g. "COUNT( * )" which
> indicates if the database may approximate the number instead of doing a
> consistent calculation. This is good for optimization scenarios where you
> don't need an actual count, just an estimate (for progress bars and similar
> stuff in UIs).
> But unfortunately we don't have any syntax support for this when dealing with
> String queries. Shouldn't we add that?
> I could imagine a prefix or something like that, e.g. the "tilde / ~" symbol,
> like this:
> {code}
> SELECT ~COUNT(*) FROM table
> {code}
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)