Github user nickwallen commented on a diff in the pull request:
@@ -40,8 +45,8 @@
Context context = new Context.Builder()
- .with(Context.Capabilities.SHELL_VARIABLES , () -> variables)
+ .with(Context.Capabilities.SHELL_VARIABLES , () ->
--- End diff --
I am actually interested in what direction as a project we should be taking
with these types of fluent, chained statements. I run across this all the time
and I want to know the 'right' way that I should be doing it for the project.
IMHO, the way it was (separated by a line break) is more readable.
Meaning, a long set of chained statements should be separated by line breaks.
result = new ProfileMeasurement()
But, of course, in terms of code style my opinion doesn't matter. It is
all about our style guidelines.
What does the Google code style guidelines say?
support what I have said above about line breaks in this case?