Ok,

I think this "dif" can stay

<dif>
   public static void appendAutoScrollAssignment(StringBuffer
onClickValue, String formName)
    {
+        onClickValue.append("if(window."+AUTO_SCROLL_FUNCTION+"!=undefined)");
+        onClickValue.append("{");
        onClickValue.append("document.forms['").append(formName).append("']");
        
onClickValue.append(".elements['").append(AUTO_SCROLL_PARAM).append("']");
-        
onClickValue.append(".value=").append(AUTO_SCROLL_FUNCTION).append(";");
+        
onClickValue.append(".value=").append(AUTO_SCROLL_FUNCTION).append("();");
+        onClickValue.append("}");
+
    }
</dif>

I'll just revert the name/param


<dif_to_revert>
-    private static final String AUTO_SCROLL_PARAM = "autoScroll";
-    private static final String AUTO_SCROLL_FUNCTION = "getScrolling()";
+    private static final String AUTO_SCROLL_PARAM =
"org_apache_myfaces_autoScroll";
+    private static final String AUTO_SCROLL_FUNCTION =
"org_apache_myfaces_getScrolling";
</dif_to_revert>

means, name it back to getScrolling()...

-Matthias

On 8/3/06, Sean Schofield <[EMAIL PROTECTED]> wrote:
> looks like all people here are
> -1 on keeping (or +1 on putting it to the 1.2 branch)
>
> I'll wait until tonight (US time) and do some stuff there;
>
> Makes sense?

Yes.  Thanks for helping (again.)

> Matthias Wessendorf

Sean



--
Matthias Wessendorf

further stuff:
blog: http://jroller.com/page/mwessendorf
mail: mwessendorf-at-gmail-dot-com

Reply via email to