It's definitely not a JDK problem. The code works fine in a non-platform
application with jdk11.0.4. It's a problem of the combination JDK 11 plus
NetBeans Platform. It fails even if I switch to JDK 11 and NetBeans 8.2.

Geertjan Wielenga <> schrieb am Sa., 12. Okt. 2019,

> So first start by using the same JDK for both to see whether it is a JDK
> problem (probably since JDK 11 is very different to JDK 8) or not.
> Gj
> On Sat, 12 Oct 2019 at 08:50, Boris Heithecker <>
> wrote:
>> Hi all,
>> it seems that a NetBeans 11.1 platform app running on Java 11 (oracle
>> jdk11.0.4) doesn't read annotations at package level properly. If I'm not
>> mistaken for whatever reason this is a really nasty bug.
>> Please have a look at this to reproduce:
>> If I run this small platform application with platform 11.1 and Java 11
>> selected, it fails (i.e. the package annotation is not found at runtime).
>> If I run it with NetBeans 8.2 and Java 8_162 the annotation is found as
>> expected.
>> I started porting a platform application yesterday which has been run on
>> 8.2 so far and which makes heavy use of JAXB and Web Services. I spend the
>> whole day digging various sources on why the application fails to run on
>> Java 11 (with Metro JAX WS RI added as external library) until I found out
>> what seems to be the obvious reason now: it fails because JAXB can't
>> read @XmlSchema-annotations in package-info. Am I doing something wrong?
>> Boris

Reply via email to