Attached are the logs after setting processors in Debug mode. Here is the
flow:

ExecuteSQL --> SplitAvro --> PublishKafkaRecord_0_10

Thanks!!

On Fri, Aug 11, 2017 at 9:01 PM, mayank rathi <mayank.ra...@gmail.com>
wrote:

> Hello All,
>
> I am moving data to Kafka using NiFi's PublishKafkaRecord processor. I am
> using ConfluentSchemaRegistry Controller service and getting below error:
>
> 2017-08-11 20:54:25,937 ERROR [Timer-Driven Process Thread-4]
> o.a.n.p.k.pubsub.PublishKafkaRecord_0_10 PublishKafkaRecord_0_10[id=
> b3c03961-015d-1000-0946-79ccbe2ffbbd] PublishKafkaRecord_0_10[id=
> b3c03961-015d-1000-0946-79ccbe2ffbbd] failed to process due to 
> java.lang.NullPointerException;
> rolling back session: {}
> java.lang.NullPointerException: null
>
> I do not see any error on Kafka side.
>
> How can I debug and resolve this issue?
>
> Thanks!!
>
> --
> NOTICE: This email message is for the sole use of the intended
> recipient(s) and may contain confidential and privileged information. Any
> unauthorized review, use, disclosure or distribution is prohibited. If you
> are not the intended recipient, please contact the sender by reply email
> and destroy all copies of the original message.
>



-- 
NOTICE: This email message is for the sole use of the intended recipient(s)
and may contain confidential and privileged information. Any unauthorized
review, use, disclosure or distribution is prohibited. If you are not the
intended recipient, please contact the sender by reply email and destroy
all copies of the original message.

Reply via email to