While working on a new contactMech type (no spoiler yet, that will come
in some days ;)), I wanted to develop the CRUD services , and stumbled
upon something that bother me.
Actually, when we update a contactMech in OFBiz, the service keep
history of it, to keep reference for related entity (like
communicationEvent and such). Thanks to that, old communication
event/invoice/etc. refer to the old contact mechanism.
That's fine with me, but what is bothering me is that
updatePostalAddress (and others) service is named like every auto-entity
CRUD services within OFBiz, that could be misleading for newcomers
I feel like we have to change the naming of these services. No good idea
yet about a new name... Am I the only one wondering about that ? Is that
fine to keep "udpate" in this context ?
Intégrateur Apache-OFBiz, ERP en logiciel Libre
8 rue des Déportés 37000 TOURS
02 47 50 30 54
| Réseau Libre Entreprise <http://www.libre-entreprise.org/>