[ 
https://issues.apache.org/jira/browse/OOZIE-2621?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15576458#comment-15576458
 ] 

Robert Kanter commented on OOZIE-2621:
--------------------------------------

[~abhishekbafna], this seems like something we should consider for 4.3.  What 
do you think?

> Use hive-exec-<version>-core instead of hive-exec in oozie-core
> ---------------------------------------------------------------
>
>                 Key: OOZIE-2621
>                 URL: https://issues.apache.org/jira/browse/OOZIE-2621
>             Project: Oozie
>          Issue Type: Bug
>            Reporter: Peter Cseh
>            Assignee: Peter Cseh
>         Attachments: OOZIE-2621.001.patch
>
>
> hive-exec.jar contains the dependencies of Hive and they can cause issues on 
> the classpath: HIVE-1640, HIVE-5733
> We've ran into and issue when Oozie won't start because of different Jackson 
> versions.
> We should use hive-exec-core.jar (HIVE-7423) instead of hive-exec.jar which 
> is a thin version of hive-exec.jar 
> Pig is already using hive-exec-core: 
> https://github.com/apache/pig/blob/spark/ivy.xml#L423



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to