[ 
https://issues.apache.org/jira/browse/OOZIE-2608?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16121404#comment-16121404
 ] 

Attila Sasvari commented on OOZIE-2608:
---------------------------------------

+1

Thanks [~gezapeti], committed to master!

> Comma in oozie.service.JPAService.jdbc.password value results in 
> authentication error
> -------------------------------------------------------------------------------------
>
>                 Key: OOZIE-2608
>                 URL: https://issues.apache.org/jira/browse/OOZIE-2608
>             Project: Oozie
>          Issue Type: Bug
>          Components: core
>    Affects Versions: 4.2.0
>         Environment: HDP 2.4 latest, Oozie 4.2.0.2.4.2.0-258
>            Reporter: Nikolai Grigoriev
>            Assignee: Peter Cseh
>            Priority: Minor
>             Fix For: 5.0.0
>
>         Attachments: OOZIE-2608-001.patch, OOZIE-2608-002.patch, 
> OOZIE-2608-003.patch
>
>
> I have attempted to install Oozie with Postgres db backend via HDP 2.4. I was 
> able to test DB connection via Ambari, everything was correct. However, the 
> server failed to start with this error:
> {code}
> 2016-07-15 11:46:39,580  INFO URIHandlerService:520 - 
> SERVER[hadoop-master01.production.sociablelabs.net] Loaded default urihandler 
> org.apache.oozie.dependency.FSURIHandler
> 2016-07-15 11:46:40,323  INFO HadoopAccessorService:520 - 
> SERVER[hadoop-master01.production.sociablelabs.net] password key is 
> oozie.service.JPAService.jdbc.password
> 2016-07-15 11:46:40,331  INFO HadoopAccessorService:520 - 
> SERVER[hadoop-master01.production.sociablelabs.net] credential provider path 
> is null
> 2016-07-15 11:46:40,337  INFO HadoopAccessorService:520 - 
> SERVER[hadoop-master01.production.sociablelabs.net] password is null
> 2016-07-15 11:46:41,176 FATAL Services:514 - 
> SERVER[hadoop-master01.production.sociablelabs.net] Runtime Exception during 
> Services Load. Check your list of 'oozie.services' or 'o
> ozie.services.ext'
> 2016-07-15 11:46:41,194 FATAL Services:514 - 
> SERVER[hadoop-master01.production.sociablelabs.net] E0103: Could not load 
> service classes, Cannot create PoolableConnectionFactory (F
> ATAL: password authentication failed for user "oozie")
> org.apache.oozie.service.ServiceException: E0103: Could not load service 
> classes, Cannot create PoolableConnectionFactory (FATAL: password 
> authentication failed for user "oozie")
>         at org.apache.oozie.service.Services.loadServices(Services.java:309)
>         at org.apache.oozie.service.Services.init(Services.java:213)
> ....
> Caused by: org.postgresql.util.PSQLException: FATAL: password authentication 
> failed for user "oozie"
>         at 
> org.postgresql.core.v3.ConnectionFactoryImpl.doAuthentication(ConnectionFactoryImpl.java:291)
>         at 
> org.postgresql.core.v3.ConnectionFactoryImpl.openConnectionImpl(ConnectionFactoryImpl.java:108)
>         at 
> org.postgresql.core.ConnectionFactory.openConnection(ConnectionFactory.java:66)
> ...
> {code}
> Schema verification at startup worked fine and I could not find any bugs 
> related to it. So, I started getting suspicious about my password value, 
> which was like "pO,e43DpjK" (not exactly but it was a bunch of letters, 
> number and one comma). I suspected that the comma was probably interpreted as 
> a value list separator so I have changed the password removing the comma. 
> Server started flawlessly.
> I am not 100% sure if it is Ambari that should be escaping (or validating?) 
> the value or Oozie that fails to read the value as single string.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Reply via email to