[ 
https://issues.apache.org/jira/browse/OOZIE-3026?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16121604#comment-16121604
 ] 

Andras Piros commented on OOZIE-3026:
-------------------------------------

[~dbist13] you're welcome. Possibly only {{openjpa.Enhance=WARN}} has to be put 
to {{persistence.xml}}. For all the other OpenJPA Log4J settings the best place 
would be {{oozie-log4j.properties}}.

> fix openjpa enhancer stage during build for logging
> ---------------------------------------------------
>
>                 Key: OOZIE-3026
>                 URL: https://issues.apache.org/jira/browse/OOZIE-3026
>             Project: Oozie
>          Issue Type: Bug
>          Components: core
>    Affects Versions: 4.3.0
>         Environment: Maven home: /usr/local/apache-maven-3.5.0
> Java version: 1.8.0_141, vendor: Oracle Corporation
> Default locale: en_US, platform encoding: UTF-8
> OS name: "mac os x", version: "10.12.6", arch: "x86_64", family: "mac"
> latest commit: 7d59ce9ba0b79a66169b6d8f1c4b941a381e549a
>            Reporter: Artem Ervits
>            Assignee: Artem Ervits
>            Priority: Minor
>             Fix For: 5.0.0
>
>         Attachments: OOZIE-3026-0.patch, OOZIE-3026-1.patch, 
> OOZIE-3026-2.patch, oozie-jpa-trace.log, oozie-jpa-warn.log
>
>
> when running mkdistro.sh script, getting the following messsage
> {noformat}
> [INFO] --- openjpa-maven-plugin:2.4.1:enhance (enhancer) @ oozie-core ---
> log4j:WARN No appenders could be found for logger (openjpa.Runtime).
> log4j:WARN Please initialize the log4j system properly.
> {noformat}
> since no appenders were found, let's disable the system altogether.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Reply via email to