[ 
https://issues.apache.org/jira/browse/OOZIE-3028?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16122310#comment-16122310
 ] 

Rohini Palaniswamy commented on OOZIE-3028:
-------------------------------------------

bq. Rohini Palaniswamy do you think it makes sense to up Jython to 2.7.1 in Pig 
and here?
  Sure. Looks like there are both bug fixes and enhancements in it - 
http://fwierzbicki.blogspot.ru/2017/07/jython-271-final-released.html

> Oozie Pig Action fails with no python dependencies
> --------------------------------------------------
>
>                 Key: OOZIE-3028
>                 URL: https://issues.apache.org/jira/browse/OOZIE-3028
>             Project: Oozie
>          Issue Type: Bug
>          Components: build
>    Affects Versions: 4.3.0
>            Reporter: Prabhu Joseph
>            Assignee: Artem Ervits
>              Labels: pig
>             Fix For: 5.0.0
>
>         Attachments: OOZIE-3028-0.patch
>
>
> Oozie Pig Action with Python script fails with below as the pig sharelib 
> jython-2.5.3.jar does not have python dependencies. We should include 
> jython-standalone jar into pig sharelib which has the right dependencies.
> {code}
> Caused by: java.lang.NoSuchFieldError: __code__
> at 
> org.apache.pig.scripting.jython.JythonFunction.<init>(JythonFunction.java:57)
>         ... 51 more
> {code}
> # /usr/hdp/current/oozie-server/bin/oozie admin -shareliblist pig |grep 
> jython 
>           
> hdfs://mycluster/user/oozie/share/lib/lib_20170106054154/pig/jython-2.5.3.jar



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Reply via email to