[ 
https://issues.apache.org/jira/browse/OOZIE-3228?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Andras Piros updated OOZIE-3228:
--------------------------------
    Attachment: OOZIE-3228.004.patch

> [Spark action] Can't load properties from spark-defaults.conf
> -------------------------------------------------------------
>
>                 Key: OOZIE-3228
>                 URL: https://issues.apache.org/jira/browse/OOZIE-3228
>             Project: Oozie
>          Issue Type: Bug
>          Components: action
>    Affects Versions: 5.0.0, 4.3.1
>            Reporter: Tang Yan
>            Assignee: Andras Piros
>            Priority: Major
>             Fix For: 5.1.0
>
>         Attachments: OOZIE-3228.001.patch, OOZIE-3228.002.patch, 
> OOZIE-3228.003.patch, OOZIE-3228.004.patch
>
>
> When I create a Oozie workflow to launch a spark action, the spark job can't 
> load the configured properties in {{spark-defaults.conf}}. I've configured 
> each NodeManager as the Spark gateway role, so {{spark-defaults.conf}} is 
> generated in {{/etc/spark/conf/}} on each worker node.
> In {{spark-defaults.conf}} some configuration I've set into.
> {noformat}
> spark.executor.extraClassPath=/etc/hbase/conf:/etc/hive/conf
> spark.driver.extraClassPath=/etc/hbase/conf:/etc/hive/conf
> {noformat}
> But in the Oozie spark job, they're not loaded automatically.
> {noformat}
> --conf spark.executor.extraClassPath=$PWD/*
> --conf spark.driver.extraClassPath=$PWD/*
> {noformat}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to