[ 
https://issues.apache.org/jira/browse/OOZIE-3278?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16511462#comment-16511462
 ] 

Julia Kinga Marton edited comment on OOZIE-3278 at 6/13/18 5:38 PM:
--------------------------------------------------------------------

Checked with the following versions of Hadoop: 2.6.0, 3.0.1, 3.1.0. 


was (Author: kmarton):
Checked with the following versions: 2.6.0, 3.0.1, 3.1.0. 

> Oozie fails to start with Hadoop 2.6.0
> --------------------------------------
>
>                 Key: OOZIE-3278
>                 URL: https://issues.apache.org/jira/browse/OOZIE-3278
>             Project: Oozie
>          Issue Type: Bug
>    Affects Versions: 5.0.0
>            Reporter: Julia Kinga Marton
>            Assignee: Julia Kinga Marton
>            Priority: Major
>         Attachments: OOZIE-3278-001.patch
>
>
> Oozie is failing to start with Hadoop 2.6.0 with the following error:
>  
> {code:java}
> Validate DB Connection
> Exception in thread "main" java.lang.NoClassDefFoundError: 
> org/apache/hadoop/util/ReflectionUtils
>  at org.apache.oozie.service.Services.setServiceInternal(Services.java:377)
>  at org.apache.oozie.service.Services.<init>(Services.java:111)
>  at org.apache.oozie.tools.OozieDBCLI.getJdbcConf(OozieDBCLI.java:169)
>  at org.apache.oozie.tools.OozieDBCLI.createConnection(OozieDBCLI.java:918)
>  at org.apache.oozie.tools.OozieDBCLI.validateConnection(OozieDBCLI.java:926)
>  at org.apache.oozie.tools.OozieDBCLI.createDB(OozieDBCLI.java:188)
>  at org.apache.oozie.tools.OozieDBCLI.run(OozieDBCLI.java:131)
>  at org.apache.oozie.tools.OozieDBCLI.main(OozieDBCLI.java:79)
> Caused by: java.lang.ClassNotFoundException: 
> org.apache.hadoop.util.ReflectionUtils
>  at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
>  at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
>  at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:338)
>  at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
> {code}
>  
> The scope of hadoop-common dependency should be changed to compile, if this 
> dependency here is really needed:
> [https://github.com/apache/oozie/blob/master/webapp/pom.xml#L152-L156]
>  
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to