Andras Salamon created OOZIE-3303:
-------------------------------------

             Summary: Oozie UI does not work
                 Key: OOZIE-3303
                 URL: https://issues.apache.org/jira/browse/OOZIE-3303
             Project: Oozie
          Issue Type: Bug
          Components: build, ui
    Affects Versions: 5.1.0
         Environment: Mac OS X

Java 8 u171

Hadoop 2.6.0
            Reporter: Andras Salamon


When latest {{master}} Oozie is built locally with Hadoop version 2.6.0, and 
{{bin/oozied.sh start}} is issued, reaching the UI or accessing CLI results in 
following error message:
{noformat}
{"errorMessage":"org.apache.jasper.JasperException: Unable to compile class for 
JSP","httpStatusCode":500}
{noformat}
Server side error message in {{logs/jetty.log}} is:
{noformat}
2018-07-11 14:57:18,956  INFO Server:414 - Started @6514ms
2018-07-11 14:57:46,110  WARN ServletHandler:624 - 
org.apache.jasper.JasperException: Unable to compile class for JSP
        at 
org.apache.jasper.compiler.DefaultErrorHandler.javacError(DefaultErrorHandler.java:116)
        ...
        at org.apache.oozie.servlet.AuthFilter$2.doFilter(AuthFilter.java:171)
        at 
org.apache.hadoop.security.authentication.server.AuthenticationFilter.doFilter(AuthenticationFilter.java:572)
        at 
org.apache.hadoop.security.authentication.server.AuthenticationFilter.doFilter(AuthenticationFilter.java:542)
        at org.apache.oozie.servlet.AuthFilter.doFilter(AuthFilter.java:176)
        ...
        at java.lang.Thread.run(Thread.java:748)
Caused by: Unable to find a javac compiler;
com.sun.tools.javac.Main is not on the classpath.
Perhaps JAVA_HOME does not point to the JDK.
It is currently set to 
"/Library/Java/JavaVirtualMachines/jdk1.8.0_171.jdk/Contents/Home/jre"
        at 
org.apache.tools.ant.taskdefs.compilers.CompilerAdapterFactory.getCompiler(CompilerAdapterFactory.java:129)
        ...
        at 
org.apache.jasper.compiler.AntCompiler.generateClass(AntCompiler.java:233)
        ... 60 more
{noformat}

>From CLI, following is the error message:
{noformat}
$ bin/oozie admin -oozie http://localhost:11000 -status
log4j:WARN No appenders could be found for logger 
(org.apache.hadoop.security.authentication.client.KerberosAuthenticator).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more 
info.
Error: IO_ERROR : java.io.IOException: Error while connecting Oozie server. No 
of retries = 1. Exception = Could not authenticate, Authentication failed, 
status: 404, message: Not Found
{noformat}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to