[ 
https://issues.apache.org/jira/browse/OOZIE-3514?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17016206#comment-17016206
 ] 

Koji Noguchi commented on OOZIE-3514:
-------------------------------------

bq. Rohini Palaniswamy, any news on the Pig release?
http://mail-archives.apache.org/mod_mbox/pig-dev/202001.mbox/%3CCABBupGUNeqGKHDvPEj-ow0aNe_PSqVAhDg0wFaeitPy9THcOFQ%40mail.gmail.com%3E
Aiming for early Feb.

> Investigate the future of the Pig action
> ----------------------------------------
>
>                 Key: OOZIE-3514
>                 URL: https://issues.apache.org/jira/browse/OOZIE-3514
>             Project: Oozie
>          Issue Type: Bug
>            Reporter: Andras Salamon
>            Priority: Blocker
>             Fix For: 6.0
>
>
> Pig is one of the oldest actions in Oozie, it was part of the original open 
> source release.
> Right now one important Oozie task ( OOZIE-2973 - Make sure Oozie works with 
> Hadoop 3 ) is blocked by a PIG issue ( PIG-5253 ) for a very long time and I 
> don't really think this issue will be solved soon:
>  * The latest Pig version (0.17) was released almost 2 years ago.
>  * There are only [6 commits|https://github.com/apache/pig/commits/trunk] in 
> the project in 2019.
> I think sooner or later we have to choose if we want to support Hadoop 3 or 
> Pig, and Hadoop3 is much more important for Oozie. I think we may consider 
> dropping Pig support. Of course such a big change should only targeted to 
> 6.0, but we could already make it deprecated in the next minor (5.2) version.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Reply via email to