I like that design a lot better, I'll go ahead and change it.
On Wed, Mar 23, 2011 at 10:15 AM, Ben Pfaff <[email protected]> wrote: > On Tue, Mar 22, 2011 at 06:32:55PM -0700, Ethan Jackson wrote: >> Creates a new function compose_packet() which replaces >> compose_lacp_packet(). The CFM code uses this function as well. > > It seems reasonable to have a function like this. I'm not as happy > about compose_packet() doing a memory copy. Not that it would > normally matter, but it seems unnecessary. Would it be reasonable for > it to just take a size and return a pointer to the start of that > space? The function would look a lot like make_openflow() but it > would insert an Ethernet header instead of an OpenFlow header. > _______________________________________________ dev mailing list [email protected] http://openvswitch.org/mailman/listinfo/dev
