Sounds good. I will change to "complete" and merge. Ethan
On Fri, Apr 29, 2011 at 15:59, Ben Pfaff <[email protected]> wrote: > On Fri, Apr 29, 2011 at 03:50:08PM -0700, Ethan Jackson wrote: >> I was borderline on doing something like this. In the case where the dump >> doesn't complete successfully, the LRU list will essentially be >> re-initialized. >> Without the following incremental, you could end up in a situation where the >> LRU list is always completely repopulated by the dump code and thus useless. >> With this patch, you could end up in a situation where the dumps are never >> successful and all of the ports leak. Both are extreme edge cases. I >> suppose >> the following incremental is more correct. > > Thanks, I like it better that way. > > 'success' is a misnomer though, since nl_dump_next() also returns > false to report an error. Maybe 'complete'? With that change (which > I don't need to see again), this looks good to me. > > Thanks, > > Ben. > _______________________________________________ dev mailing list [email protected] http://openvswitch.org/mailman/listinfo/dev
