On 04/07/2015 08:56 PM, Justin Pettit wrote:
> It was confusing having a database called "ovn", since it's also the
> name of the project. Since we have an "ovn-nb", rename "ovn" to
> "ovn-sb".
>
> Signed-off-by: Justin Pettit <[email protected]>
Fine with me. I agree that it would make it more clear.
One minor comment:
> diff --git a/ovn/ovn-nbd.c b/ovn/ovn-nbd.c
> index 637d8cf..a8cbc9c 100644
> --- a/ovn/ovn-nbd.c
> +++ b/ovn/ovn-nbd.c
> @@ -24,7 +24,7 @@
> #include "fatal-signal.h"
> #include "hash.h"
> #include "hmap.h"
> -#include "ovn/ovn-idl.h"
> +#include "ovn/ovn-sb-idl.h"
> #include "ovn/ovn-nb-idl.h"
> #include "poll-loop.h"
> #include "stream.h"
> @@ -37,13 +37,13 @@ VLOG_DEFINE_THIS_MODULE(ovn_nbd);
>
> struct nbd_context {
> struct ovsdb_idl *ovnnb_idl;
> - struct ovsdb_idl *ovn_idl;
> + struct ovsdb_idl *ovnsb_idl;
> struct ovsdb_idl_txn *ovnnb_txn;
> struct ovsdb_idl_txn *ovn_txn;
"ovn_txn" should probably become "ovnsb_txn" for consistency here.
--
Russell Bryant
_______________________________________________
dev mailing list
[email protected]
http://openvswitch.org/mailman/listinfo/dev