[ 
https://issues.apache.org/jira/browse/OWB-1150?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15506144#comment-15506144
 ] 

Moritz Bechler commented on OWB-1150:
-------------------------------------

I guess both options would be okay. [2.2,4.0) seems cleaner if it is explicitly 
unsupported. On the other hand, if we expect the servlet spec to be backward 
compatible keeping it open saves the trouble of adjusting once in a while.

> OSGI bundle version ranges too restrictive
> ------------------------------------------
>
>                 Key: OWB-1150
>                 URL: https://issues.apache.org/jira/browse/OWB-1150
>             Project: OpenWebBeans
>          Issue Type: Bug
>    Affects Versions: 1.7.0
>            Reporter: Moritz Bechler
>
> openwebbeans-web imports javax.servlet* [2.6,3) and javax.el [2.2,3). 
> openwebbeans-el22 imports javax.el [2.2,3). 
> This is way too restrictive, they used to have no upper restrictions.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to