Yes, and I am planning on writing 2 subclasses to Apache::PerlSections
to handle either a namespace name, or a hash ref, as in:

package My::Config;
$Location{'/foo'} = { [...] };
@Alias = qw(/this /that);
 and
Apache::PerlSection->add_namespace("My::Config");

or

my %My::Config = (
        'Location' => { '/foo' => { [...]}},
        'Alias' => qw(/this /that),
);
 and
Apache::PerlSection->add_hash(\%My::Config);

ah, it can be an array or a scalar too, so a more generic name would be a better choice, I believe. just call it add()? or add_var()?


Also if you prototype add() to accept an SV, you won't need to pass a reference, which is confusing in the case of a scalar.

In which case we may want to provide an equivalent to add_config() as well. Since they all add config. e.g. have:

Apache::PerlSection->add_namespace("My::Config");
Apache::PerlSection->add_string("User $foo");
my %hash = ...;
Apache::PerlSection->add(%hash);

notice that add_string is exactly the same as $s->add_config.

__________________________________________________________________
Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
http://stason.org/     mod_perl Guide ---> http://perl.apache.org
mailto:[EMAIL PROTECTED] http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com


--------------------------------------------------------------------- To unsubscribe, e-mail: [EMAIL PROTECTED] For additional commands, e-mail: [EMAIL PROTECTED]



Reply via email to