Question:
- how should we name the defines for exception codes? I did MODPERL_CONST_EXIT for the EXIT exception. Or should it be MODPERL_ERROR_EXIT or else?
I think it's confusing on the C side to have CONST (since it has nothing to do with const in C). I think I'll call it either:
MODPERL_RC_EXIT
or
MODPERL_CODE_EXIT
Most likely the former, so all ReturnCodes added by ModPerl will live in MODPERL_RC_, which makes the C code easier to grok:
if (sv_derived_from(sv, "ModPerl::Error") &&
SvIVx(sv) == MODPERL_RC_EXIT) {
/* ModPerl::Util::exit was called */
return OK;-- __________________________________________________________________ Stas Bekman JAm_pH ------> Just Another mod_perl Hacker http://stason.org/ mod_perl Guide ---> http://perl.apache.org mailto:[EMAIL PROTECTED] http://use.perl.org http://apacheweek.com http://modperlbook.org http://apache.org http://ticketmaster.com
--------------------------------------------------------------------- To unsubscribe, e-mail: [EMAIL PROTECTED] For additional commands, e-mail: [EMAIL PROTECTED]
