[
https://issues.apache.org/jira/browse/PHOENIX-2774?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15196641#comment-15196641
]
James Taylor commented on PHOENIX-2774:
---------------------------------------
I like it, [~churromorales]. WDYT, [~jesse_yates]? Are we losing anything by
not deriving from NonLazyKeyValueScanner and in particular having this code:
{code}
@Override
public boolean requestSeek(Cell kv, boolean forward, boolean useBloom)
throws IOException {
return doRealSeek(this, kv, forward);
}
public static boolean doRealSeek(KeyValueScanner scanner,
Cell kv, boolean forward) throws IOException {
return forward ? scanner.reseek(kv) : scanner.seek(kv);
}
{code}
Minor nit - maybe rename PhoenixKeyValueScanner to ReseekableScanner or
something like that?
> MemStoreScanner and KeyValueStore should not be aware of KeyValueScanner
> ------------------------------------------------------------------------
>
> Key: PHOENIX-2774
> URL: https://issues.apache.org/jira/browse/PHOENIX-2774
> Project: Phoenix
> Issue Type: Task
> Affects Versions: 4.8.0
> Reporter: churro morales
> Assignee: churro morales
> Attachments: PHOENIX-2774.patch
>
>
> Relates to PHOENIX-2756, trying to remove all dependencies on @Private
> interfaces in HBase.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)