[ 
https://issues.apache.org/jira/browse/PHOENIX-5636?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Christine Feng updated PHOENIX-5636:
------------------------------------
    Attachment: PHOENIX-5636.master.v8.patch

> Improve the error message when client connects to server with higher major 
> version
> ----------------------------------------------------------------------------------
>
>                 Key: PHOENIX-5636
>                 URL: https://issues.apache.org/jira/browse/PHOENIX-5636
>             Project: Phoenix
>          Issue Type: Bug
>    Affects Versions: 4.15.0
>            Reporter: Sandeep Guggilam
>            Assignee: Christine Feng
>            Priority: Minor
>              Labels: beginner, newbie
>             Fix For: 4.15.1
>
>         Attachments: PHOENIX-5636.master.v1.patch, 
> PHOENIX-5636.master.v2.patch, PHOENIX-5636.master.v3.patch, 
> PHOENIX-5636.master.v4.patch, PHOENIX-5636.master.v5.patch, 
> PHOENIX-5636.master.v6.patch, PHOENIX-5636.master.v7.patch, 
> PHOENIX-5636.master.v8.patch
>
>          Time Spent: 1h
>  Remaining Estimate: 0h
>
> When a 4.14 client connects to a 5.0 server, it errors out saying " Outdated 
> jars. Newer Phoenix clients can't communicate with older Phoenix servers"
> It should probably error out with "Major version of client is less than that 
> of the server"



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Reply via email to