Feel free to optimize it.
Zhenbing Feng <[email protected]> 于2021年5月26日周三 上午12:13写道:
> When I configure `shenyu.httpclient.strategy=netty ` to use
> NettyClientResponsePlugin.
>
>
> I have found some magic number here in NettyClientResponsePlugin
>
> @Override
> public int getOrder() {
> return 100;
> }
>
> @Override
> public String named() {
> return "NettyClientResponse";
> }
>
>
> Should we optimize the code to avoid using magic number like this
>
> @Override
> public int getOrder() {
> return PluginEnum.RESPONSE.getCode();
> }
>
> @Override
> public String named() {
> return PluginEnum.RESPONSE.getName();
> }
>