[ 
https://issues.apache.org/jira/browse/SLING-6170?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Bertrand Delacretaz updated SLING-6170:
---------------------------------------
    Fix Version/s: Crankstart Launcher 2.0.0

> Crankstart launcher tests fail with Java 1.8
> --------------------------------------------
>
>                 Key: SLING-6170
>                 URL: https://issues.apache.org/jira/browse/SLING-6170
>             Project: Sling
>          Issue Type: Bug
>          Components: Crankstart
>            Reporter: Bertrand Delacretaz
>            Assignee: Bertrand Delacretaz
>            Priority: Minor
>             Fix For: Crankstart Launcher 2.0.0
>
>
> The contrib/crankstart/launcher build fails with Java 1.8 due to the 
> {{org.apache.sling.crankstart.test.services}} bundle not starting as the 
> framework (bundle 0) has an empty {{Provide-Capability}} header - so the 
> bundle is missing the {{(&(osgi.ee=JavaSE)(version=1.5))}} requirement.
> Interestingly, if I start a Sling instance manually with the same 
> provisioning model and JVM, that bundle starts and {{Provide-Capability}} is 
> correctly populated.
> The startup command for that is
> {code}
>  rm -rf CRANKSTART ; \
> java -jar \
> target/org.apache.sling.crankstart.launcher-1.9.9-SNAPSHOT.jar \
> src/test/resources/crankstart-model.txt src/test/resources/provisioning-model
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to