[
https://issues.apache.org/jira/browse/SLING-6976?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16057422#comment-16057422
]
Stefan Seifert commented on SLING-6976:
---------------------------------------
for the patch: what about making detectMimeTypeFromName accept multiple paths
as varargs, and passing in both classpath resource path and target path. if for
any of them a mime type can be detected it is chosen, then falling back to the
default.
i think there is no need to deprecated the methods without mimetype.
> ContentLoader.binaryFile() and ContentLoader.binaryResource() should try to
> derive mimetype from classpath resource rather than from target resource name
> ---------------------------------------------------------------------------------------------------------------------------------------------------------
>
> Key: SLING-6976
> URL: https://issues.apache.org/jira/browse/SLING-6976
> Project: Sling
> Issue Type: Bug
> Components: Testing
> Affects Versions: Testing Sling Mock 2.2.12
> Reporter: Konrad Windszus
> Attachments: SLING-6976-v01.patch
>
>
> Currently the {{ContentLoader.binaryFile}} tries to derive the mime type from
> the target resource name which should contain the binary
> (https://github.com/apache/sling/blob/trunk/testing/mocks/sling-mock/src/main/java/org/apache/sling/testing/mock/sling/loader/ContentLoader.java#L226).
> This is often useless, as the resource name almost never contains an
> extension from which a mimetype could be derived (very often a generic name
> like "file" is used). Instead the first argument (namely
> {{classpathResource}} should be taken as basis to derive the mime type from).
> Currently in practically all cases the mime type will be set to the default
> value
> (https://github.com/apache/sling/blob/trunk/testing/mocks/sling-mock/src/main/java/org/apache/sling/testing/mock/sling/loader/ContentLoader.java#L466)
> which is {{application/octet-stream}}.
--
This message was sent by Atlassian JIRA
(v6.4.14#64029)