[ 
https://issues.apache.org/jira/browse/SLING-7025?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Radu Cotescu closed SLING-7025.
-------------------------------

> htl-maven-plugin: Correctly state default values for include parameter
> ----------------------------------------------------------------------
>
>                 Key: SLING-7025
>                 URL: https://issues.apache.org/jira/browse/SLING-7025
>             Project: Sling
>          Issue Type: Bug
>          Components: Maven Plugins and Archetypes
>    Affects Versions: HTL Maven Plugin 1.0.6
>            Reporter: Konrad Windszus
>            Assignee: Radu Cotescu
>             Fix For: HTL Maven Plugin 1.0.8
>
>         Attachments: SLING-7025-v01.patch
>
>
> Right now the default values for the {{includes}} are set programmatically 
> within 
> https://github.com/apache/sling/blob/trunk/tooling/maven/htl-maven-plugin/src/main/java/org/apache/sling/maven/htl/ValidateMojo.java#L217.
>  That leads to the fact that the default value does not appear in the 
> generated Maven site: 
> http://sling.apache.org/components/htl-maven-plugin/validate-mojo.html.
> Please rather give the default via the annotation 
> (https://maven.apache.org/plugin-tools/maven-plugin-tools-annotations/index.html#Supported_Annotations).
>  You can even give multiple values as comma separated string 
> (http://blog.sonatype.com/2011/03/configuring-plugin-goals-in-maven-3/). Due 
> to https://issues.apache.org/jira/browse/MNG-5440 you should increase the 
> minimum supported maven version to 3.3.9.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Reply via email to