Robert Munteanu created SLING-7042:

             Summary: Launchpad does not start with Java 9 RC1
                 Key: SLING-7042
             Project: Sling
          Issue Type: Bug
          Components: Launchpad
            Reporter: Robert Munteanu
         Attachments: sling-java9.log

I tried to start Sling 10-SNAPSHOT with the latest Java 9 RC:

{noformat}$ /opt/jdk-9/bin/java -version
java version "9"
Java(TM) SE Runtime Environment (build 9+181)
Java HotSpot(TM) 64-Bit Server VM (build 9+181, mixed mode){noformat}

It fails to start with the following error ( full console log attached )

{noformat}ERROR: Error parsing system bundle export statement: org.osgi.dto; 
version=1.0.0, org.osgi.framework; version=1.8.0, org.osgi.framework.dto; 
version=1.8.0, org.osgi.framework.hooks.bundle; version=1.1.0, 
org.osgi.framework.hooks.resolver; version=1.0.0, 
org.osgi.framework.hooks.service; version=1.1.0, 
org.osgi.framework.hooks.weaving; version=1.1.0, org.osgi.framework.launch; 
version=1.2.0, org.osgi.framework.namespace; version=1.1.0, 
org.osgi.framework.startlevel; version=1.0.0, 
org.osgi.framework.startlevel.dto; version=1.0.0, org.osgi.framework.wiring; 
version=1.2.0, org.osgi.framework.wiring.dto; version=1.2.0, org.osgi.resource; 
version=1.0.0, org.osgi.resource.dto; version=1.0.0, 
org.osgi.service.packageadmin; version=1.2.0, org.osgi.service.resolver; 
version=1.0.0, org.osgi.service.startlevel; version=1.1.0, 
org.osgi.service.url; version=1.0.0, org.osgi.util.tracker; version=1.5.1,;version=1.2.0,  
org.osgi.framework.BundleException: Exported package names cannot be zero 

I've tried the Felix 5.6.6 distribution and it worked fine with the same Java 9 
build, so the error is likely in Sling somewhere.

This message was sent by Atlassian JIRA

Reply via email to