frederic rougeot commented on SLING-7457:

I tried first with OAk Segment Tar and it is OK for me.

The next step was using MongoDB.

I said in previous comment It was OK now, but it is not the case right now ...

I checked that the sling database is created in mongodb, it is OK and I thought 
everything was fine.

But now I got the following HTTP 403 ... when accessing to http:/localhost:8080 
just to see how sling react now it is linked with mongodb ...

Once again, I think the documentation should help !

h1. Forbidden (403)

The requested URL resulted in an error in 
h3. Request Progress:

0 TIMER_START\{Request Processing} 0 COMMENT timer_end format is \{<elapsed 
msec>,<timer name>} <optional message> 0 LOG Method=GET, PathInfo= 0 
TIMER_START\{ResourceResolution} 2 TIMER_END\{2,ResourceResolution} URI= 
resolves to Resource=NoSqlResource, type=nt:unstructured, superType=null, 
path=/ 2 LOG Resource Path Info: SlingRequestPathInfo: path='/', 
selectorString='null', extension='null', suffix='null' 2 
TIMER_START\{ServletResolution} 2 TIMER_START\{resolveServlet(NoSqlResource, 
type=nt:unstructured, superType=null, path=/)} 2 
TIMER_END\{0,resolveServlet(NoSqlResource, type=nt:unstructured, 
superType=null, path=/)} Using servlet 
org.apache.sling.servlets.get.DefaultGetServlet 2 
TIMER_END\{0,ServletResolution} URI= handled by 
Servlet=org.apache.sling.servlets.get.DefaultGetServlet 3 LOG Applying 
Requestfilters 3 LOG Calling filter: 
org.apache.sling.engine.impl.debug.RequestProgressTrackerLogFilter 3 LOG 
Calling filter: org.apache.sling.i18n.impl.I18NFilter 3 LOG Applying 
Componentfilters 3 
TIMER_START\{org.apache.sling.servlets.get.DefaultGetServlet#0} 3 LOG Using 
org.apache.sling.servlets.get.impl.helpers.StreamRendererServlet to render for 
extension=null 5 LOG Applying Error filters 5 LOG Calling filter: 
org.apache.sling.i18n.impl.I18NFilter 5 TIMER_START\{handleError:status=403} 40 
TIMER_END\{35,handleError:status=403} Using handler 
41 TIMER_END\{41,Request Processing} Dumping SlingRequestProgressTracker Entries

> Poor documentation on mongoDB or other NOSQL use
> ------------------------------------------------
>                 Key: SLING-7457
>                 URL: https://issues.apache.org/jira/browse/SLING-7457
>             Project: Sling
>          Issue Type: Bug
>          Components: Documentation
>            Reporter: frederic rougeot
>            Priority: Major
> I am evaluating sling.
> I succeed in setting it up and it works as I thought, seems to be a very 
> valuable product for those who want to rapidlly build a software that relies 
> on JCR, which is my case.
> But the next question is "Should I use a noSQL Database or not". As it may be 
> an important choice, since Sling is not really compatible with SQL database, 
> I wanted to make sling run with MongoDB.
> I read the documentation, and at first impression, it seemed quite immediate; 
> I simply have to add an option to change the mode of launching the starter 
> application, as it is said in the following documentation: 
> [https://sling.apache.org/documentation/the-sling-engine/the-sling-launchpad.html]
> So I tried to launch the starter application with the following lines:
> java -Dsling.run.modes=oak,oak_mongo -jar 
> org.apache.sling.starter-10-SNAPSHOT.jar
> and checked with a mongodb client if a mongodb server was started or not ...
> As I was unable to connect to mongodb://localhost:27017 I guess something is 
> missing, maybe mongodb should be installed separetely ? 
> I continue reading the documentation, and find 
> [https://sling.apache.org/documentation/bundles/nosql-resource-providers.html]
> OK, my conclusion was I missed to install the nosql-resource-providers, so I 
> installed the bundle and check again ...
> Nothing new, it seems I have done nothing.
> So, always according to 
> [https://sling.apache.org/documentation/bundles/nosql-resource-providers.html,]
>  there is another launchpad to use.
> There is the link to the source code: 
> https://github.com/apache/sling-old-svn-mirror/tree/trunk/contrib/nosql/launchpad
> But it is said that this source repository is obsolete and shall not be used.
> So I get back to apache git repository, and filtered on "sling" and "nosql", 
> I can find some code now ...
> https://github.com/apache?utf8=%E2%9C%93&q=sling+nosql&type=&language=
> But it is absolutely not clear to me whether I have to do something with that 
> modules or not ...
> So my real problem is I can't get the right documentation on "How to setup 
> Sling 9 to work with mongodb" and there is, as far as I know, no forum where 
> I can ask this to a community to help.
> I guess sling is working well with mongoDB, but if I need 10 days to set it 
> up (I spend 1 day, maybe it is not enough) my point of view is made: I won't 
> use mongodb.
> But this maybe a terrible mistake !
> So help please !

This message was sent by Atlassian JIRA

Reply via email to