I am using Solr 9.6 in an application with more than 10M documents indexed.
Around 50% of them are PDF or office documents that need extraction.
Whenever I need to reindex (for example, when upgrading the Solr version),
I usually start 5 parallel processes, which works fine.

Now, while testing Solr 10 in containers and configured to use TikaServer
(running in a separate container), I found that as soon as I start a second
indexing process, Solr throws errors like this:

2026-09-21 15:35:49.117 ERROR (qtp1917025677-36-null-745) [ x:documents
t:null-745] o.a.s.s.HttpSolrCall 500 Exception
=>org.apache.solr.common.SolrException: org.xml.sax.SAXException: FWK005
parse may not be called while parsing. at
org.apache.solr.handler.extraction.ExtractingDocumentLoader.load(ExtractingDocumentLoader.java:202)

Gemini suggested that this issue is caused by the reuse of a SAXParser.
Following that, I tried looking into the source code with GitHub Copilot,
and it suggested a fix by modifying TikaServerParser.java.

I would appreciate it if someone could validate this behavior and provide a
fix in upcoming versions.
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]

Reply via email to