[ 
https://issues.apache.org/jira/browse/SQOOP-3016?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15581407#comment-15581407
 ] 

Kingsly J commented on SQOOP-3016:
----------------------------------

Hi Team,
Any updates on this issue, please?

Regards,
Kingsly J

> warehouse-dir or target-dir is not being honored 
> -------------------------------------------------
>
>                 Key: SQOOP-3016
>                 URL: https://issues.apache.org/jira/browse/SQOOP-3016
>             Project: Sqoop
>          Issue Type: Bug
>          Components: connectors/hdfs
>    Affects Versions: 1.4.5
>         Environment: CDH 5.4.7
>            Reporter: Kingsly J
>
> Hi Team,
> In our QA env, we are not having sudo access and not having folder in our 
> username in "/user" and not having write access to the same. Hence we used 
> --warhouse-dir to direct the result to the directory for which we are having 
> write access.we tried the below sqoop statement to load data from Teradata to 
> hdfs,
> sqoop import --connect jdbc:teradata://<ip>/Database=test,LOGMECH=LDAP 
> --username abc -P --table tbl1 --split-by tbl_cd --warehouse-dir 
> /projects/Sqoop_Test
> but getting the below error,
> ERROR tool.ImportTool: Encountered IOException running import job: 
> com.teradata.connector.common.exception.ConnectorException: 
> org.apache.hadoop.security.AccessControlException: Permission denied: 
> user=abc, access=WRITE, inode="/user":hdfs:supergroup:drwxr-xr-x
> It is still trying to write to "/user" path. we have tried with --target-dir 
> parameter also, and still getting the same error.
> Please guide us on the same.
> Regards,
> Kingsly J



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to