Dear Rupert
> On Wed, Feb 13, 2013 at 3:12 PM, Reto Bachmann-Gmür <[email protected]> > wrote: > > On Wed, Feb 13, 2013 at 2:59 PM, Rupert Westenthaler > <[email protected]> wrote: >> [...] >> In the meantime I will commit my current version as the UserManager >> does work nice locally > > If by that you mean the version in which the usermanager takes care > about the ld-details I strongly disagree. So I replied within 13 minutes that I "strongly disagree". A disagreement which shouldn't have come as a surprise given the previous discussion. Yet you commit the changes with the comment: STANBOL-910: temporary fix to the UserManager as discussed in [1]. See > follow up discussion for the proposed final solution. > > [1] http://markmail.org/message/aje7c3mucstph4oy > > With all appreciation of the great work you did and are still doing for Stanbol I think that here you're showing little respect for the processes of collaborative development. If asked to rollback code you committed on a yet unresolved issue you should do so unless your alternative remedy approach find a clear consensus. I've now rollbacked the changes and reintegrated major portions of your improvement (using the BundleTemplateLoader). Still as it is now the UserManager can work as it used to work. My impression is that the whole "refactoring" happened with little consideration of my opinion as the original author of the code. For example you renamed packages despite my scepticism: On Tue, Feb 5, 2013 at 2:35 PM, Reto Bachmann-Gmür <[email protected]> wrote: > On Tue, Feb 5, 2013 at 12:59 PM, Rupert Westenthaler > <[email protected]> wrote: >> I suggest also move the two Viewable classes to the >> 'org.apache.stanbol.commons.web.viewable' package and keep deprecated >> version in the original pakcage for backward compatibility. > > > Not sure if the renaming is needed. After all this is just tuple of a > resource and an abstract rendering instruction, this can be used for the web > as well as for other purposes such as e.g. for email. Now on this point I don't have a very strong opinion and I can live with your change. Yet I think it would be an advantage if this wouldn't be part of a huge "refactoring" of both API, implementation of functionality but if things could be split into smaller issues were one can also more easily veto and a change can be undone without major implication on other issues. The renaming of the package would be such a small change. While I have no problem admitting that the original code around LDPAthTemplate /RdfViewable had some design flaws and there was room for improvement I must say that I'm a bit irritated by the activism you have shown in addressing exactly this. On one hand as the flaws mainly affected implementation internal and not the API bits intented for usage in other modules so there was no rush. On the other hand because there are so many areas in Stanbol API which would benefit so much from a refactoring. (Thinking at CORS, ServletContext abuse, services requiring mutable queries, services with identical set of methods but no common interface, ...). We all try to make Stanbol better, lets give each other some room and honest criticism, but lets avoid stepping on each other feet jeopardizing productivity. Cheers, Reto
