Thanks Reto, Rupert, direct it is then.
On 18 February 2013 13:22, Rupert Westenthaler <[email protected]> wrote: > Hi Danny, all > > I prefer directly returning data based on the Accept header over > sending redirects to content type specific URIs as the later involves > additional RTT (round trip times). > > best > Rupert > > On Mon, Feb 18, 2013 at 1:04 PM, Danny Ayers <[email protected]> wrote: >> Reto just mentioned: >> [[ >> I'm working on the >> archetype which shows how RESTfull services can be build. Stanbol was >> always about REST, yet we are not yet providing a single REST service. With >> the RDF based frontend we get closer to this. As standard RDF formats and >> well defined ontologies will satisfy the hypermedia requirement of REST. >> ]] >> >> I'm putting RESTful access in place in User Management (as well as >> browser-based and Web 2.0 style APIs). I'm just wondering if we need a >> separate naming scheme for URIs that are addressing the RDF data, >> something vaguely along the lines of dbPedia's ./page (for HTML) and >> ./resource (for RDF), or whether simply ignoring that distinction and >> just keying off media type is preferable. >> >> Currently I've got e.g. - >> >> Get user Turtle : >> >> curl --user admin:admin -H "Accept:text/turtle" >> http://localhost:8080/user-management/users/anonymous >> >> Any thoughts? >> >> Cheers, >> Danny. >> >> -- >> http://dannyayers.com >> >> http://webbeep.it - text to tones and back again > > > > -- > | Rupert Westenthaler [email protected] > | Bodenlehenstraße 11 ++43-699-11108907 > | A-5500 Bischofshofen -- http://dannyayers.com http://webbeep.it - text to tones and back again
