Hi,

While doing a sync up merge to my branch, I noticed some subtree mergeinfo being recorded and decided to look into it's validity. I could trace it back to r1054277.

In this revision, stefan2 made a copy of libsvn_diff/diff.h as libsvn_subr/adler32.c, presumably using a 1.5.x client (x < 5) because, this resulted in an 'empty' svn:mergeinfo property being set on the file. I say 1.5.x where x<5 because this was fixed in 1.5.5:

<snip from CHANGES file>
...
Version 1.5.5
(22 Dec 2008, from /branches/1.5.x)
http://svn.apache.org/repos/asf/subversion/tags/1.5.5

 User-visible changes:
...
* do not create mergeinfo for wc-wc moves or copies (r34184, -585))
...
</snip from CHANGES file>

This 'empty' mergeinfo has caused all future merges to record subtree mergeinfo onto this file.

I'd like to know if it is safe to remove this mergeinfo for good.


$ svn log -v -c1054277 https://svn.apache.org/repos/asf/subversion/trunk
------------------------------------------------------------------------
r1054277 | stefan2 | 2011-01-02 01:32:36 +0530 (Sun, 02 Jan 2011) | 17 lines
Changed paths:
A /subversion/trunk/subversion/include/private/svn_adler32.h (from /subversion/trunk/subversion/libsvn_diff/diff.h:1054248)
   M /subversion/trunk/subversion/libsvn_diff/diff.h
   M /subversion/trunk/subversion/libsvn_diff/diff_file.c
   M /subversion/trunk/subversion/libsvn_diff/diff_memory.c
   M /subversion/trunk/subversion/libsvn_diff/util.c
*A /subversion/trunk/subversion/libsvn_subr/adler32.c (from /subversion/trunk/subversion/libsvn_diff/util.c:1054251)*

Move & rename svn_diff__adler32 to svn__adler32 to make it available
to e.g. svnlib_delta where I will use it soon.

* subversion/libsvn_subr/adler32.c
  (ADLER_MOD_BASE): moved from libsvn_diff/util.c
  (svn__adler32): moved and renamed from libsvn_diff/util.c
* subversion/include/private/svn_adler32.h
  (svn__adler32): moved declaration from libsvn_diff/diff.h
* subversion/libsvn_diff/util.c
  (ADLER_MOD_BASE, svn_diff__adler32): moved
* subversion/libsvn_diff/diff.c
  (svn_diff__adler32): moved

* subversion/libsvn_diff/diff_memory.c
  (datasource_get_next_token): adapt to renamed adler32() function
* subversion/libsvn_diff/diff_file.c
  (datasource_get_next_token): dito
------------------------------------------------------------------------

Regards,
Arwin Arni

Reply via email to