Bert Huijben wrote: > Julian Foad wrote: >> 1) svn_wc_check_root(*is_wcroot,*is_switched,*kind,...) >> 3) svn_wc__db_is_switched(*is_wcroot,*is_switched,*kind,...) >> >> Would it work to call (1) and (3) 'svn_wc...check_root_and_switched'? >> >> It's a bit long but more accurate. > > I don't see a real problem with a function that checks for several kinds of > root, and returns different answers that allows you to determine what a root > is > for you. > (Thanks for the current changes)
My pleasure. > Why create such a long function name? > > I'm not sure if it tells more than the current name, and it is not complete > either. [...] My specific points are: * We have two current names (1) and (3) for exactly the same functionality. * We are trying to make the names clear and consistent. * We presently have another function (set of functions) called 'is_wcroot' which provides a subset of this functionality. So I'm going to make the two names the same (modulo the '__db' part), and I'm going to make them in some way reflect that checking for a 'root' is part of their functionality. Ideally I'd like the name to reflect that they do more than that. The word 'check' is a rather weak cue for that, but it already exists and I want a simple acceptable solution. So, I'll stick with the name 'check_root' and just change (3) to match it, so we'll have: 1) svn_wc_check_root(*is_wcroot,*is_switched,*kind,...) 3) svn_wc__db_check_root(*is_wcroot,*is_switched,*kind,...) 5) svn_wc__is_wcroot(*is_wcroot,...) 6) svn_wc__db_is_wcroot(*is_wcroot,...) and 4) svn_wc_is_wc_root2(*wc_root,...) remains as the deprecated WC-1 function with a different meaning of 'root'. - Julian