I have nothing to add to Stefan and James' review of functionality, so here are a couple of style suggestions:
Lukas Jirkovsky wrote on Wed, May 03, 2017 at 23:03:42 +0200: > +++ subversion/libsvn_subr/gpg_agent.c (working copy) > @@ -225,6 +228,46 @@ > +find_gpgconf_agent_socket(apr_pool_t *pool) > +{ > + apr_proc_t proc; > + svn_stringbuf_t *line; > + svn_error_t *err; > + const char *gpgargv[] = { "gpgconf", "--list-dir", "agent-socket", NULL }; > + You could add the second const here (after the asterisk) to remove the need for the cast? > + /* execute "gpgconf --list-dir agent-socket" */ > + err = svn_io_start_cmd3(&proc, NULL, "gpgconf", (const char* > const*)gpgargv, > + NULL, TRUE, FALSE, NULL, TRUE, NULL, FALSE, NULL, > + pool); Add "/* inherit */", "/* infile_pipe */", etc comments after the booleans? (That's how we simulate Python's keyword arguments in C.) Not trying to nitpick; just to make the code easier to read. Cheers, Daniel