Summary:

    +1 to release (Unix)

Platform

    macOS High Sierra 10.13.3

    Standard dependencies:
      Apple LLVM version 9.0.0 (clang-900.0.39.2)
      ruby 2.3.3p222 (2016-11-21 revision 56859)
      Python 2.7.10

    Dependencies from Homebrew:
      APR 1.6.3
      APR-Util 1.6.1
      httpd 2.4.29
      SQLite 3.22.0
      Serf 1.3.9
      OpenSSL 1.0.2n
      zlib 1.2.11
      BDB 6.2.32
      Perl 5.26.1
      Swig 3.0.12

    Other dependencies:
      Java 1.8.0_45-b14
      JUnit 4.11

    Built-in dependencies:
      LZ4
      utf8proc

Verified:

  - Tarball contents and signatures
  - check ((fsfs, bdb) × (local, svnserve, dav))
  - check-all-javahl
  - check-swig-py
  - check-swig-rb
  - check-swig-pl

New issues:

  - Warning from JavaHL build:

    subversion/bindings/javahl/native/SVNRepos.cpp:371:15: warning: 
'svn_repos_load_fs5'
          is deprecated [-Wdeprecated-declarations]
      SVN_JNI_ERR(svn_repos_load_fs5(repos, dataIn.getStream(requestPool),

Known issues:

  - 'make check-swig-py' requires 'make install install-swig-py'.
    Probably a side effect of macOS "security" features related to the
    use of the DYLD_LIBRARY_PATH environment variable.

  - 'make check-swig-rb' requires 'make install install-swig-rb'.
    Probably a side effect of macOS "security" features related to the
    use of the DYLD_LIBRARY_PATH environment variable.

 GPG signatures committed to the dist/dev/subversion repository.

-- Brane

Reply via email to