Hi all,

I've experienced the bug mentioned in the title. No matter which
browser - tried with Chromium 60, Firefox 54, Midori, Epiphany,
QupZilla, even Dillo, but all of the browsers crash dwm when opening
these links in them (disabling javascript does not help):


I use Arch Linux. Only dwm is affected, the links open with no problem
under i3. I've tried with the dwm package from the Arch repo (which
was built using the unmodified config.h I guess), cloning the git repo
and compiling myself with the vanilla config, but nothing changes: the
result is a crash when opening these links.

> $ dwm -v
> dwm-6.1

> $ uname -a
> Linux cygnus 4.12.4-1-ARCH #1 SMP PREEMPT Fri Jul 28 18:54:18 UTC 2017 x86_64 
> GNU/Linux

> # X -version
> X.Org X Server 1.19.3
> Release Date: 2017-03-15
> X Protocol Version 11, Revision 0
> Build Operating System: Linux 4.9.11-1-ARCH x86_64
> Current Operating System: Linux cygnus 4.12.4-1-ARCH #1 SMP PREEMPT Fri Jul 
> 28 18:54:18 UTC 2017 x86_64
> Kernel command line: BOOT_IMAGE=../vmlinuz-linux 
> cryptdevice=UUID=769e9004-25d9-404f-bb6f-a238e3083294:cryptroot 
> root=/dev/mapper/cryptroot rw initrd=../initramfs-linux.img
> Build Date: 07 April 2017  05:42:48PM
> Current version of pixman: 0.34.0
>         Before reporting problems, check http://wiki.x.org
>         to make sure that you have the latest version.

Some logs (using the dwm package from Arch repo):

After opening links with Chromium:

dwm's stderr: https://pastebin.com/raw/1j31WMJd
Xorg.0.log: https://pastebin.com/raw/mzCYF0B4
Journal (output of journalctl -e as root): https://pastebin.com/raw/wDQRwyp7

Same with Firefox:

dwm's stdout: https://pastebin.com/raw/A5TUhC3u
dwm's stderr: https://pastebin.com/raw/xtQMyF2P
Xorg.0.log: https://pastebin.com/raw/JBYG7A2e
Journal (output of journalctl -e as root): https://pastebin.com/raw/GJwePQLc

Reply via email to